Results 1 to 3 of 3

Thread: Magellan Triton 400

  1. #1
    Join Date
    Jan 2009
    Posts
    3

    Magellan Triton 400

    I have a new Triton that has worked well since I bought it. The last 2 times I've been out caching it's hung up on me and gone totally haywire. If I want to pick a new cache to go to, it hangs upand I have to pull the batteries. After a couple of minutes I can turn it back on and it may or may not work. I've already tried totally wiping it out and starting over but it did it again today. I'm using NiCad rechargable batteries, and I've tried just disposable. Any thoughts??

    I've had this trouble with my old Garmin, but never had this issue with my other Magellan.
    ~Amy

  2. #2
    Join Date
    Jan 2007
    Location
    Russellville
    Posts
    569
    You might try Download the latest software update: v1.46 from the website http://www.magellangps.com/support/prod ... rodid=1910 If that don't work, there may be a master reset that you have to use a toothpick to push inside the battery compartment. Let us know if you get it working, if not check out the link above and see what happens


    Crow Mountain Crafts FB Page

  3. #3
    Join Date
    Jan 2009
    Posts
    3
    I'll try the software download. I haven't been able to find a master reset yet, but maybe I'm not looking the right place. Thanks for the tip!
    ~Amy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •